Just a short post on upgrading to ESXi 5.1 (not supported) I’ve upgraded my HP Microserver N40L to ESXi 5.1. And it is working just fine.